aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAnna (navi) Figueiredo Gomes <navi@vlhl.dev>2023-03-14 18:50:04 -0300
committerAnna (navi) Figueiredo Gomes <navi@vlhl.dev>2023-10-19 10:56:54 +0200
commitc1134b3ce72b1ee3b28897bcc9c355c68fa6f388 (patch)
tree6e3adc68a6d716ab578b70ba95cd7372c5d4181f /meson.build
parent554ccab718147e04203c424ac10916071bfa7aee (diff)
librc: skeleton of user services support
Those functions allocates and set up the environment for user services. Signed-off-by: Anna (navi) Figueiredo Gomes <navi@vlhl.dev>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9f4fc5ee..a9345e4c 100644
--- a/meson.build
+++ b/meson.build
@@ -59,6 +59,12 @@ else
cc_pam_flags = []
endif
+if get_option('user_services')
+ cc_user_services_flags = '-DRC_USER_SERVICES'
+else
+ cc_user_services_flags = []
+endif
+
if not pam_dep.found() and get_option('pam')
error('Pam was requested but could not be located')
endif