aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-20 12:05:56 +0000
committerWilliam Hubbs <w.d.hubbs@gmail.com>2021-11-20 17:31:17 -0600
commitbd5cdaafadf997c0ab3c4ad362dbdfd7dc6fd987 (patch)
treed6fc43d5a0edbc79ae078881192f344bd45ab16d /meson.build
parent015c83761d4b75abf2f5e2bf72cc7361d41130bc (diff)
meson: fix pam_misc_dep definition
X-Gentoo-Bug: 824954 X-Gentoo-Bug-URL: https://bugs.gentoo.org/824954 Fixes: https://github.com/OpenRC/openrc/issues/470 Fixes: https://github.com/OpenRC/openrc/pull/477
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 5210861e..8af45560 100644
--- a/meson.build
+++ b/meson.build
@@ -94,6 +94,7 @@ rc_sbindir = rc_libexecdir / 'sbin'
sbindir = rootprefix / get_option('sbindir')
selinux_dep = dependency('libselinux', required : get_option('selinux'))
+pam_misc_dep = []
if selinux_dep.found()
cc_selinux_flags = '-DHAVE_SELINUX'
if pam_dep.found() and get_option('pam')
@@ -107,7 +108,6 @@ if selinux_dep.found()
endif
else
cc_selinux_flags = []
- pam_misc_dep = []
endif
termcap = get_option('termcap')