summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorPaul Botros <pbotros1234@gmail.com>2019-11-03 22:00:55 -0800
committerPaul Botros <pbotros1234@gmail.com>2019-11-03 22:01:28 -0800
commitf052fd1adde4a106a2e06955a2b5886e9de501eb (patch)
tree0eeda967161771d0d5df0597ac743a15617a1dac /CMakeLists.txt
parente777b0295eeeda89ee2ecef6ec5cb54889033d94 (diff)
Adding an option to DISABLE_TESTS
Useful when hiredis is used as a CMake dependency in other projects and added via add_subdirectory(). With DISABLE_TESTS on, `make test` in the parent project won't run hiredis tests.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9e78894..fcd8d4b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,6 +3,7 @@ INCLUDE(GNUInstallDirs)
PROJECT(hiredis)
OPTION(ENABLE_SSL "Build hiredis_ssl for SSL support" OFF)
+OPTION(DISABLE_TESTS "If tests should be compiled or not" OFF)
MACRO(getVersionBit name)
SET(VERSION_REGEX "^#define ${name} (.+)$")
@@ -76,7 +77,7 @@ IF(ENABLE_SSL)
DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
ENDIF()
-IF(NOT (WIN32 OR MINGW))
+IF(NOT (DISABLE_TESTS OR (WIN32 OR MINGW)))
ENABLE_TESTING()
ADD_EXECUTABLE(hiredis-test test.c)
TARGET_LINK_LIBRARIES(hiredis-test hiredis)