summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlessio M <masariello@gmail.com>2020-09-09 17:27:28 +0100
committerAlessio M <masariello@gmail.com>2020-09-09 17:27:28 +0100
commitdde6916b42a4723b364355eff8fbb477723a789a (patch)
tree051f91f5f7d511b61dafaff5a397c68acd32e96f /CMakeLists.txt
parent3b68b5018e87ca259c5f5b5f6ee23b445c8fab14 (diff)
Add d suffix to debug libraries so that can packaged together with optimized builds (Release, RelWithDebInfo, etc)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 12ef75b..40769c1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,7 +24,8 @@ PROJECT(hiredis VERSION "${VERSION}")
# Hiredis requires C99
SET(CMAKE_C_STANDARD 99)
-set(CMAKE_POSITION_INDEPENDENT_CODE ON)
+SET(CMAKE_POSITION_INDEPENDENT_CODE ON)
+SET(CMAKE_DEBUG_POSTFIX d) # so debug and optimized can be packaged together
SET(ENABLE_EXAMPLES OFF CACHE BOOL "Enable building hiredis examples")