summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorkevin1018 <wangxk1028@gmail.com>2019-07-17 19:05:06 +0800
committerGitHub <noreply@github.com>2019-07-17 19:05:06 +0800
commit8249e67355e60246fb109f0d98d0b92834fd30e8 (patch)
treee53228f9a090f14ef39b7cecc404186374b14123 /CMakeLists.txt
parentf5f855c91239706b173e2412cea301f4a3643e2d (diff)
Add install adapters header files
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c8c8071..30140bf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -47,7 +47,10 @@ INSTALL(TARGETS hiredis
INSTALL(FILES hiredis.h read.h sds.h async.h
DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/hiredis)
-
+
+INSTALL(DIRECTORY adapters
+ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/hiredis)
+
INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/hiredis.pc
DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)