summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBjorn Svensson <bjorn.a.svensson@est.tech>2022-09-27 18:56:42 +0200
committerGitHub <noreply@github.com>2022-09-27 09:56:42 -0700
commit6d5c3ee74d05d8b7d1bda49a1342fa00ccfc3367 (patch)
tree08f22604c286da8a896750810355c4fbc61bb186 /CMakeLists.txt
parent68b29e1ad509f45af8a6ca9486463d9a57a391f1 (diff)
Install on windows fixes (#1117)
* Remove attempt to install .pdb file for windows static lib From ff57c18b (#1054) the debug information was embedded in the windows static lib rather than creating a .pdb file. Removing the installation step of this file in CMake when building with buildtype Debug or RelWithDebInfo. * Embed debug information in windows hiredis_ssl_static lib See ff57c18b (#1054) for same change in library hiredis_static.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt18
1 files changed, 6 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ee03add..e8bcd0e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -58,8 +58,8 @@ SET_TARGET_PROPERTIES(hiredis
PROPERTIES WINDOWS_EXPORT_ALL_SYMBOLS TRUE
VERSION "${HIREDIS_SONAME}")
IF(WIN32)
-SET_TARGET_PROPERTIES(hiredis_static
- PROPERTIES COMPILE_FLAGS /Z7)
+ SET_TARGET_PROPERTIES(hiredis_static
+ PROPERTIES COMPILE_FLAGS /Z7)
ENDIF()
IF(WIN32 OR MINGW)
TARGET_LINK_LIBRARIES(hiredis PUBLIC ws2_32 crypt32)
@@ -113,9 +113,6 @@ if (MSVC)
INSTALL(FILES $<TARGET_PDB_FILE:hiredis>
DESTINATION ${CMAKE_INSTALL_BINDIR}
CONFIGURATIONS Debug RelWithDebInfo)
- INSTALL(FILES $<TARGET_FILE_DIR:hiredis_static>/$<TARGET_FILE_BASE_NAME:hiredis_static>.pdb
- DESTINATION ${CMAKE_INSTALL_LIBDIR}
- CONFIGURATIONS Debug RelWithDebInfo)
endif()
# For NuGet packages
@@ -181,10 +178,10 @@ IF(ENABLE_SSL)
PROPERTIES
WINDOWS_EXPORT_ALL_SYMBOLS TRUE
VERSION "${HIREDIS_SONAME}")
- SET_TARGET_PROPERTIES(hiredis_ssl_static
- PROPERTIES COMPILE_PDB_NAME hiredis_ssl_static)
- SET_TARGET_PROPERTIES(hiredis_ssl_static
- PROPERTIES COMPILE_PDB_NAME_DEBUG hiredis_ssl_static${CMAKE_DEBUG_POSTFIX})
+ IF(WIN32)
+ SET_TARGET_PROPERTIES(hiredis_ssl_static
+ PROPERTIES COMPILE_FLAGS /Z7)
+ ENDIF()
TARGET_INCLUDE_DIRECTORIES(hiredis_ssl PRIVATE "${OPENSSL_INCLUDE_DIR}")
TARGET_INCLUDE_DIRECTORIES(hiredis_ssl_static PRIVATE "${OPENSSL_INCLUDE_DIR}")
@@ -206,9 +203,6 @@ IF(ENABLE_SSL)
INSTALL(FILES $<TARGET_PDB_FILE:hiredis_ssl>
DESTINATION ${CMAKE_INSTALL_BINDIR}
CONFIGURATIONS Debug RelWithDebInfo)
- INSTALL(FILES $<TARGET_FILE_DIR:hiredis_ssl_static>/$<TARGET_FILE_BASE_NAME:hiredis_ssl_static>.pdb
- DESTINATION ${CMAKE_INSTALL_LIBDIR}
- CONFIGURATIONS Debug RelWithDebInfo)
endif()
INSTALL(FILES hiredis_ssl.h