summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authormichael-grunder <michael.grunder@gmail.com>2020-08-28 12:35:01 -0700
committermichael-grunder <michael.grunder@gmail.com>2020-08-28 12:35:20 -0700
commit13a35bdb64615e381c5e1151cdd4e78bba71a6db (patch)
tree0f98bf69cc2a7c4e60318f490aed684139786421 /CMakeLists.txt
parentbea137ca945a131f01159358ee76567992198e58 (diff)
Explicitly set c99 in CMake
See #869
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1beccc6..4cbd438 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,6 +22,9 @@ MESSAGE("Detected version: ${VERSION}")
PROJECT(hiredis VERSION "${VERSION}")
+# Hiredis requires C99
+SET(CMAKE_C_STANDARD 99)
+
SET(ENABLE_EXAMPLES OFF CACHE BOOL "Enable building hiredis examples")
SET(hiredis_sources