summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJustin Brewer <jzb0012@auburn.edu>2019-01-21 15:05:04 -0600
committerMark Nunberg <mnunberg@haskalah.org>2019-02-20 05:01:08 -0500
commit0c57a083c702609d3e65789338ea2477de92c6f3 (patch)
treed2d5827608fd00ecb5232b86dd70a0fddaf1b9fb /CMakeLists.txt
parentbbad21f5cac8295e83e4d118d450aaa32e4435d8 (diff)
Add ENABLE_EXAMPLES option, off by default
Signed-off-by: Justin Brewer <jzb0012@auburn.edu>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f3a87f6..d5df625 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,6 +2,8 @@ CMAKE_MINIMUM_REQUIRED(VERSION 3.0.0)
INCLUDE(GNUInstallDirs)
PROJECT(redisearch)
+SET(ENABLE_EXAMPLES OFF CACHE BOOL "Enable building hiredis examples")
+
# Get the version numbers
MACRO(getVersionBit name)
@@ -46,5 +48,6 @@ ADD_EXECUTABLE(hiredis-test
TARGET_LINK_LIBRARIES(hiredis-test hiredis)
# Add examples
-ADD_SUBDIRECTORY(examples)
-
+IF(ENABLE_EXAMPLES)
+ ADD_SUBDIRECTORY(examples)
+ENDIF(ENABLE_EXAMPLES)